Increased Check Processing Time
Incident Report for LEM Verify
Resolved
Check processing performance has now returned to normal bounds and most new checks should now be processed within SLA. We apologies for any issues the delays in processing may have caused.
Posted Feb 10, 2021 - 21:19 UTC
Update
We are continuing to experience delayed check processing for all manually processed checks.
Posted Feb 10, 2021 - 21:07 UTC
Update
We are continuing to work on a fix for this issue.
Posted Feb 10, 2021 - 19:04 UTC
Update
We are continuing to work on a fix for this issue.
Posted Feb 10, 2021 - 17:27 UTC
Identified
We are experiencing increased check processing times for all manually processed checks due to an increase in volume. We are working on increasing processing capacity
Posted Feb 10, 2021 - 17:27 UTC
This incident affected: Verification Services (Document Processing).